Join the Discussion:

Very slow, glitchy

Is there any preferred browser to use with webydo? I've found it to be EXTREMELY slow and glitchy using chrome .... it also completely shut down in firefox so I'm guessing that's not a good one to use either. If it's not the browser, PLEASE find some way to make the website less glitchy. From reading topics I see I am not the only one having this problem, so I know it's not just my internet/computer.

40 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    10 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • AlanaAdminAlana (Forum Admin, Webydo) commented  ·   ·  Flag as inappropriate

        Hello,

        Please contact us immediately with the following information so we can look into this.
        Sent the email to support@webydo.com

        SID:
        Geo location:
        Your ISP:
        Your Internet Bandwidth:
        Time and date of incident:
        Device (MAC/PC/Mobile):
        Browser version:
        Was it the Studio/Dashboard/Publisher?:
        The page of the site you were working on:
        Which element you are editing (if there is a specific one):
        When did slowness start? (at the beginning of work or after X amount of time?)
        Does it happen a lot or just right now?

        Thank you!

      • ********** commented  ·   ·  Flag as inappropriate

        I have been trying to edit one page for nearly an hour! I am working on Macbook Air, my broadband speed is over 100MB, I cleared all cookies and browsing history from google chrome and it's still extremely slow! I actually ready to switch back to Adobe Muse. Please do something about it. I have already contacted the support but nothing happened!

      • SE WisemanSE Wiseman commented  ·   ·  Flag as inappropriate

        I am using a Windows 10 OS, Edge browser with an i7 processor that includes 8GB of RAM. I can't even enter text without having to wait and wait and wait. I will contact support...when they are back in the office.

      • AlanaAdminAlana (Forum Admin, Webydo) commented  ·   ·  Flag as inappropriate

        Hello,

        Have you contacted support yet?

        If you are having problems we will be more than happy to take a look at your site and see why it could be working slowly.

        I will also speak with our tech department regarding the servers. So that you are updated, we are using Google Cloud's servers and so the locations are based on Google. But I will see if there is something in addition we will be able to do.

        Alana
        Webydo Support & Training Manager

      • Anonymous commented  ·   ·  Flag as inappropriate

        Unfortunately I am also have similar problems. I have been putting them down to my machine so far but having read a few of these comments I am not so sure.
        Over the two years Approx that I have been with Webydo I must admit that I have noticed a general slowing down going on. Some times I have to wait more than 30 sec for a connection. Quite often I have to reload a site that has so-say finished loading but hasn't.
        I am in NZ and I have been told that so latency may be due to the link to the nearest server in Singapore(via Australia.
        I guess that some of this is down to the success of Webydo (which it deserves). Volume must be increasing. So what to do? Getting a faster machine with more on board memory may help, but for us out here on the periphery, I think that webydo needs to come up with something that will help. Perhaps the easiest would be a machine optimization script which would enable us to eliminate local network problems ( I am sure that you have expertise in this area) but ideally cloud servers based in NZ or Australia.
        I use window 10 pro,chrome on an oldish HP Intel Core 2 desktop.and have net work speeds of:Latency 11ms, jitter 3ms, download speed 36.76 Mbps, Upload 6.85Mbps

      • AlanaAdminAlana (Forum Admin, Webydo) commented  ·   ·  Flag as inappropriate

        Hello,

        Whenever you are having issues of this sort, please contact support@webydo.com

        We are here to help you 7 days a week via live chat or email.

        We will do our best to figure out what may be causing the issues, to help solve and prevent them from happening in the future.

        Alana
        Webydo Support & Training Manager

      • TiareTiare commented  ·   ·  Flag as inappropriate

        I'm totally experiencing the same issue. On several different devices (iPad 3, Dell 15" Laptop/Internet Explorer, Chromebook 13"/Chrome, Dell Desktop/Firefox) I have varying problems with elements shifting. I have opened up my screen pixel size from 960 to 1220 and remained within the blue boundaries and still my content shifts. On a government computer (Dell Desk/Firefox) the website froze his computer and forced it to shut down. I 've contacted Chat and my account mgr, they try their very best to help but say I have to wait til December for the glitches to be fixed. Since this is a client website, Dec is unreasonable esp with our contract launch date being tomorrow. I need help with this please! I don't want this to affect my business and credibility. Can someone speed up the resolve for this issue? please... Mahalo!

      Feedback and Knowledge Base